Jasmine-jQuery v2 adding support for Jasmine v2

I released Jasmine-jQuery v2.0.0 which adds support for Jasmine v2.0.0.

Jasmine v2 removed support for replacing built-in matchers, which Jasmine-jQuery made use of to replace toBe() and toContain(), so there are API changes:

  • toBe() is now toEqual()
  • toContain() is now toContainElement()

Go get it.

Meanwhile, I’ll see about patching Jasmine to re-add that feature…


Follow me on Twitter to keep up with what I’ve learned building my personal finance tool, Stash.

Read more posts …
Written: January 13th, 2014
Categories: jasmine-jquery, jasmine, jquery